Issues with tomplayer_v0.240b3

Any problem with TomPlayer ? you can ask here

Issues with tomplayer_v0.240b3

Postby wolfgar » 27 Mar 2011, 22:14

Please post here your issues with the beta3 release !
Wolfgar
User avatar
wolfgar
Site Admin
 
Posts: 1881
Joined: 26 Feb 2008, 22:15

Re: Issues with tomplayer_v0.240b3

Postby erkan3300 » 28 Mar 2011, 11:36

carminat tomtom bt controls
Main menu
- Arrow or joystick to navigate among icons.
- BACK to cancel current screen-----------OK
- MAP for OK on the current screen
- Up left button |__ enables to decrease brightness-----------OK
- up right button __| enables to increase brightness-----------OK


While playing

-> If menu is hidden (video) or selection is disabled (audio) then :

MENU : Show menu (video) or Enable selection (audio)----------OK
BACK : Stop the audio or video and quit to tomplayer menu-------OK
UP : Previous track------------------------------------------------------OK
DOWN : Next track------------------------------------------------------OK
LEFT : backward---------------------------------------------------------OK
RIGHT : forward--------------------------------------------------------OK
ENTER : pause-----------------------------------------------------------OK
|__ : decrease brightness--------------------------------------------OK
__| : increase brightness---------------------------------------------OK
MAP : Display time-----------------------------------------------------OK
DEST : Mute
REPEAT : volume -
LIGHT : volume +

MENU or BACK : Hide menu (video) or Disable selection (audio)------------OK
LEFT : Navigate control-------------------OK
RIGHT : Navigate control---------------OK
ENTER : Action associated to the selected control-----------OK
|__ : decrease brightness----------OK
__| : increase brightness----------OK

-> While on screen saver :
MENU : to leave screen saver
Note : If screen saver turned on as you you were not in selection mode then all standard shortcuts still apply : UP : Previous track, DOWN : Next track etc...---------------------------OK

and play audio :) thank you wolfgar
erkan3300
Nouveau membre
 
Posts: 9
Joined: 25 Mar 2011, 12:57

Re: Issues with tomplayer_v0.240b3

Postby MARCOSOFT » 28 Mar 2011, 16:44

Hi Wolfgar,
I tested the new version and I detected the following problems:
- The new screensaver is very nice and helpful, but my time zone is GMT and show GMT+1. I edited the tomplayergui.sh and changed the TZ = CEST to TZ = GMT, but still displays GMT+1!
- Sometimes, while on screensaver, to leave screensaver I press MENU and stop the music, returning to the main menu (not always)!
- That mp3 file that did not play, now plays normally, but the mp3 file that played only a few seconds, when it was active the screensaver, now just not play, returning to the main menu!
I yet not tested with screensaver diaporama (photos).

You need to send the mp3 file that played just a few seconds and now can not play? Or has it?

Sorry for my English ...

Regards

Marcosoft
MARCOSOFT
Membre
 
Posts: 77
Joined: 24 Feb 2011, 14:53

Re: Issues with tomplayer_v0.240b3

Postby erkan3300 » 28 Mar 2011, 17:30

wolfgar v0.240b3 help me

my car megane 3 carminat tomtom remote bt

tomplayer to day update play video 4minutes freereze screen and no close tomplayer
car close 4 haurs same screen :( freereze no work tomplayer...
erkan3300
Nouveau membre
 
Posts: 9
Joined: 25 Mar 2011, 12:57

Re: Issues with tomplayer_v0.240b3

Postby claudiot88 » 28 Mar 2011, 17:45

had happened to me, with the previous version of tomplayer.

I solved it by removing the fuse for a few seconds. I have a Clio
claudiot88
Membre
 
Posts: 53
Joined: 05 Mar 2011, 15:23

Re: Issues with tomplayer_v0.240b3

Postby Thirteen » 28 Mar 2011, 20:06

I've also tested the version - and it works very well! I've just one problem at the moment: The MP3 Function (by the way, I almost never use this function, tomplayer is for me mainly used to watch videos). There is like other users had reported the bug, that by some songs the player stops playing and returns to main menu.

But except this one, I can just say: Great Job Wolfgar! BT Control works without problem, time is synchronized perfectly, play duration also works fine, etc.
Thirteen
Membre
 
Posts: 55
Joined: 12 Dec 2010, 14:00

Re: Issues with tomplayer_v0.240b3

Postby wolfgar » 28 Mar 2011, 21:43

MARCOSOFT wrote:Hi Wolfgar,
I tested the new version and I detected the following problems:
- The new screensaver is very nice and helpful, but my time zone is GMT and show GMT+1. I edited the tomplayergui.sh and changed the TZ = CEST to TZ = GMT, but still displays GMT+1!
- Sometimes, while on screensaver, to leave screensaver I press MENU and stop the music, returning to the main menu (not always)!
- That mp3 file that did not play, now plays normally, but the mp3 file that played only a few seconds, when it was active the screensaver, now just not play, returning to the main menu!
I yet not tested with screensaver diaporama (photos).


1-
If you are in GMT time zone, edit tomplayergui.sh and change the line :
Code: Select all
export TZ=CEST-2

to
Code: Select all
export TZ=BST-1

(Remember we are in daylight saving since yesterday ;-) )

2-
This is strange. I cannot explain it for now.
But it will setup a special version with debug logs to try to figure out what is wrong !
I have tested this hundred of times both with a native build and on my tomtom without being able to see this bug...

3-
I have your 3 samples :They all play fine on my tomtom with 0.240b3 !
Again, i don't understand what can be wrong... But my instrumented version will help. I send it as soon as it is ready...

Regards
User avatar
wolfgar
Site Admin
 
Posts: 1881
Joined: 26 Feb 2008, 22:15

Re: Issues with tomplayer_v0.240b3

Postby wolfgar » 28 Mar 2011, 21:57

erkan3300 wrote:wolfgar v0.240b3 help me

my car megane 3 carminat tomtom remote bt

tomplayer to day update play video 4minutes freereze screen and no close tomplayer
car close 4 haurs same screen :( freereze no work tomplayer...


To reboot your tomtom: Remove the fuse a few seconds ...
It is reported from time to time (very rare) if you know how to reproduce this issue please tell us...
User avatar
wolfgar
Site Admin
 
Posts: 1881
Joined: 26 Feb 2008, 22:15

Re: Issues with tomplayer_v0.240b3

Postby erkan3300 » 29 Mar 2011, 02:15

will not open again.
always remains open.
which is to remove the fuse?
erkan3300
Nouveau membre
 
Posts: 9
Joined: 25 Mar 2011, 12:57

Re: Issues with tomplayer_v0.240b3

Postby wolfgar » 29 Mar 2011, 20:51

the fuse protects your electric circuit ... By removing the right fuse for a few seconds you will properly reboot your tomtom...
User avatar
wolfgar
Site Admin
 
Posts: 1881
Joined: 26 Feb 2008, 22:15

Re: Issues with tomplayer_v0.240b3

Postby wolfgar » 29 Mar 2011, 20:57

Hi there

Here is a new start_engine which solves some sporadic crashs (immediate return to main menu)
Thanks to marcosoft for reporting this bug and providing his samples...

Best regards

Wolfgar
You do not have the required permissions to view the files attached to this post.
User avatar
wolfgar
Site Admin
 
Posts: 1881
Joined: 26 Feb 2008, 22:15

Re: Issues with tomplayer_v0.240b3

Postby chusebizen » 29 Mar 2011, 20:58

erkan3300 wrote:will not open again.
always remains open.
which is to remove the fuse?


Get your car manual
In fuses chapter, look for one 10A fuse described as "navigation system". Remove it wait 10 seconds and put it back again.
In my car (Grand Scenic) they are in the dashboard, at bottom-left part of the steering-wheel.
You should use the small plastic pliers that are in the cover of the fuses.

Regards,
chusebizen
Membre
 
Posts: 64
Joined: 12 Nov 2010, 23:20

Re: Issues with tomplayer_v0.240b3

Postby gasss » 29 Mar 2011, 21:39

Hi all,sorry i cannot find the beta 3,i installed beta2 and would like to try latest version?can you please provide me the download link?
and also beta 3 is a new version,or is it just a pack to add to beta2 installation? thank you :)
gasss
Nouveau membre
 
Posts: 1
Joined: 29 Mar 2011, 21:35

Re: Issues with tomplayer_v0.240b3

Postby claudiot88 » 30 Mar 2011, 10:49

Sometimes, when there is a screensaver and press the MENU button returns to main menu.
claudiot88
Membre
 
Posts: 53
Joined: 05 Mar 2011, 15:23

Re: Issues with tomplayer_v0.240b3

Postby wolfgar » 30 Mar 2011, 20:29

gasss wrote:Hi all,sorry i cannot find the beta 3,i installed beta2 and would like to try latest version?can you please provide me the download link?
and also beta 3 is a new version,or is it just a pack to add to beta2 installation? thank you :)


All releases are announced in the news section
All previous beta have a link to the latest beta
Here it is : viewtopic.php?f=21&t=929

It is not a pack but a real full package...
User avatar
wolfgar
Site Admin
 
Posts: 1881
Joined: 26 Feb 2008, 22:15

Next

Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 3 guests